Preface
Borlabs Cookie ensures compatibility with all caching systems, as the consent and unblocking processes are performed on the client side via JavaScript. In most cases, problems occur due to improper handling of caching systems, especially when the cache is improperly invalidated.
Problem
When using a caching and/or optimization system, such as a plugin like WP Rocket or Autoptimize, incorrect displays and/or JavaScript errors occur in the browser console.
Cause
Cause A - Caching
Incorrect display or non-display of settings you have made, such as changes to colors or text, is often caused by outdated caching information.
Cause B - Optimization
An error occurs in the browser console when JavaScript files are merged or compressed (minified). This is due to the fact that our modern, module-based JavaScript cannot be further optimized or merged.
Solution
Solution for Cause A
Make sure your plugin or server cache is completely empty. Also make sure that no additional caching is enabled on your server or, if used, on your content delivery network (CDN). Then check your website in incognito or private mode of your browser.
If your changes are still not visible, the cache has probably not been cleared properly, or you have more than one caching system active (e.g. plugin and server-side).
Note for WP Rocket
The " Remove cache for used CSS" action must be run after installing the WP Rocket package from the Borlabs Cookie Library.
Solution for Cause B
Please disable the merging and/or compression of JavaScript files or set your plugin not to modify the Borlabs Cookie JavaScript files in any way.
No file from the borlabs-cookie folder or with borlabs-cookie in the file path may be changed. It is not possible to specify specific file names as these change regularly.
The following plugins are known to cause problems by optimizing JavaScript files in addition to caching: Asset CleanUp, Autoptimize, Borlabs Cache, LiteSpeed Cache, Siteground Speed Optimizer, W3 Total Cache, WP Fastest Cache, WP Rocket.